(help) dpkg: error processing package initramfs-tools
by Damascus - September 14, 2021 at 08:09 AM
I was just running into some trouble updating on tails.

When i run:
sudo service start ssh
it show's a key has been created.

I also got the same error trying to install open-ssh for local connection and got the same initramfs-tools error. I did some research and tried a lot of things but nothing seams to work, any help would be highly appreciated, cheers.

I then try start the ssh it said it wasn't installed?

[email protected]:~# sudo apt-get upgrade
Reading package lists... Done
Building dependency tree     
Reading state information... Done
Calculating upgrade... Done
The following package was automatically installed and is no longer required:
Use 'sudo apt autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
[INFO] Saving package changes
Setting up initramfs-tools (0.133+deb10u1) ...
update-initramfs: deferring update (trigger activated)
ls: cannot access '/boot/vmlinuz-*': No such file or directory
cp: cannot stat '/boot/vmlinuz-*': No such file or directory
dpkg: error processing package initramfs-tools (--configure):
installed initramfs-tools package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
[INFO] Examining package changes
E: Sub-process /usr/bin/dpkg returned an error code (1)
[email protected]:~# cd /boot/
[email protected]:/boot# ls
config-5.10.0-8-amd64  grub
[email protected]:/boot#
its not open-shh
its openssh
I'll just re-install kali, i'm just being lazy.
Next time you get a dpkg error try:

sudo su

# dpkg --configure -a

# apt-get clean (clean cache)

# apt-get update or sudo apt-get -f install (force)

Possibly Related Threads…
Thread Author Replies Views Last Post
make file install error wolfhynapack9 4 2,376 July 07, 2021 at 10:09 PM
Last Post: davebrew2

 Users browsing this thread: 1 Guest(s)